How to cleanup your auto-lookup list (NK2 file)

Posted on August 22, 2010

Pretty much everyone uses the auto-lookup feature built into all versions of Outlook. You start your e-mail, enter the recipients name and BAM! The address is automatically fired into the address line and you're on your way. What happens when that list is full of old addresses, duplicates and a huge list of people you no longer require?

Outlook 2003 and 2007 maintain this particular list by storing each record into an NK2 file. If you would like to clean up the list, we recommend checking out a product by nirsoft.net.

In a matter of minutes you can load the NK2 file, trim the excess fat and have your list streamlined.

This is an excellent tool for Exchange Migrations. The NK2 file also associates local X509 addresses with the parent exchange server. This tool will allow you to delete those records and avoid resolution looks to an old exchange server after a migration.

Changing the default Address Book/Contact List

Posted on August 22, 2010

If you open the Microsoft Office Outlook 2007 Address Book and do not see the name or e-mail address you are looking for, you might need to choose another address book from the Address Book list. If you find yourself choosing another address book frequently, you can change the default address book that is displayed when you open the Address Book. By default, our Hosted Exchange customers will receive the GAL (Global Address List) instead of your local contacts folder. This can be changed to pick your contacts first.

Default contact list is not your contact list?

If you wish to change the default contact list used when you hit to:, cc:, or bcc:, please follow the steps below.

  1. Open Microsoft Outlook 2007
  2. On the Standard toolbar, click Address Book Button image

Tip You can also open the Address Book by clicking Address Book on the Tools menu.

  1. Click Tools, and then click Options.

Note If you open the Address Book from an open message, the Tools menu is not available. The Address Book must be opened by either method described in Step 1.

  1. In the Show this address list first box, click the name of the address book that you want.
  2. Click OK, and then close the Address Book.

NewPSTFormat – 2GB PST/OST Restrictions

Posted on August 22, 2010

When upgrading from Outlook 2003 to Outlook 2007 or 2010, the existing mailbox type may default to non-unicode PST/OST which will confine you to a maximum 2GB mailbox. Starting with Outlook 2007 and now Outlook 2010, a new UNICODE pst/ost format was released to allow for larger mailboxes.

To check the format on your current PST/OST:

1) Load the control panel and double-click "Mail (32-bit)"
2) Load the settings for your current PST/OST and click the "Advanced" tab
3) Near the bottom under "Mailbox Mode" you will see the type.

Unfortunately you cannot convert a non-unicode to unicode on the fly.
Ensure you backup the contents of your PST or OST file to a unique location before proceeding!!

1) Delete your current mail profile from Microsoft Outlook (use the same Mail-32 app in the control panel to do so)
2) Click Start, click run, type regedit and then click OK.
3) Locate and then click the following registry subkey:

Outlook 2007:
HKEY_CURRENT_USER\Software\Microsoft\Office\12.0\Outlook

Outlook 2010:
HKEY_CURRENT_USER\Software\Microsoft\Office\14.0\Outlook

5) Double-click NewPSTFormat.
6) In the Value data box, type the value, and then click OK.

Available Options:

* 0 - Default Unicode

If you set the NewPSTFormat registry value to 0, Outlook 2007 uses the Default Unicode setting. You can use the Default Unicode setting if you want to connect a Windows SharePoint Services list to Outlook 2007.

* 1 - Default ANSI

If you set the NewPSTFormat registry value to 1, Outlook 2007 uses the Default ANSI setting. This setting does not prevent Outlook 2007 from creating a .pst file in Unicode format for a Windows SharePoint Services list. When you add a Windows SharePoint Services list to Outlook 2007, Outlook 2007 automatically creates the .pst file in Unicode format to store the list information.

* 2 - Enforce Unicode creation (THIS SETTING IS RECOMMENDED)

If you set the NewPSTFormat registry value to 2, Outlook 2007 creates Unicode pst files for any automatically created pst file (for example, a SharePoint pst). If you manually create a new pst file, you can only create Unicode pst files because the ANSI pst option is disabled. If you have an existing ANSI pst file, it can be used with your Outlook profile.

* 3 - Enforce ANSI creation

If you set the NewPSTFormat registry value to 3, Outlook uses the Enforce ANSI creation setting. Using this setting prevents Outlook 2007 from creating a .pst file in Unicode format. You cannot use the Enforce ANSI creation setting if you want to connect a Windows SharePoint Services list to Outlook 2007.

7) Click Exit on File menu to exit Registry Editor.
8) Open Microsoft Outlook and re-create youre mail profile
9) Return to the start of this document and check what the format your newly created PST or OST.
10) If you confirm Unicode and you are NOT connected to an Exchange Server, import your backed up PST contents.

Your PST or OST file should utilize the new unicode format and grow past 2GB.